
 Contents  Index  Search - Search -

 Preface
 Introduction
 Installation
 Tutorials
 Main Window

 Introduction
 Topics

 Overview
 Control/Status Bar
 Preview/Live Broadcast Area
 Countdown Clock Display
 Transition Controls
 Shot Tool Menu
 Shot Selection Area
 Layers
 AutoLive
 Live Icons

 Keyboard Shortcuts
 Adding Media
 Titles
 Logos
 Shot Editor
 Source Settings
 Playlist
 Social Media
 Replay
 Preferences
 Audio Inspector
 Asset Manager
 Menus and Windows
 Broadcasting
 Encoder Presets
 Making Great Broadcasts

Home > Main Window

Main Window

Introduction
This section describes in detail how to use Wirecast’s main window.

Topics
n   Overview
n   Control/Status Bar
n   Preview/Live Broadcast Area
n   Countdown Clock Display
n   Transition Controls
n   Shot Tool Menu
n   Shot Selection Area
n   Layers
n   AutoLive
n   Live Icons

Overview
Wirecast’s main window is comprised of these display areas:

•    Controls/Status Area The top area with the Stream and Record buttons.

•    Preview/Live Broadcast Area The large area in the center.

•    Transition Controls The area with the Transition (Cut and Smooth) and Go buttons.

•    Shot Selection Area The area displaying the shot icons (available shots).
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Control/Status Bar
Control buttons and status information are displayed at the top of the Main window.

    

 

Wirecast displays  the following controls and statistics:

•    Stream button Click to begin streaming.

•    Streaming time This displays how long you have been streaming. This value does not reset when you start/stop the
broadcast. It is cumulative. This enables you to save portions of a broadcast to disk and still know the total amount
of time.

•    Record Button Click to begin recording.

•    Recording Time This displays how long you have been recording. This value does not reset when you start/stop the
broadcast. It is cumulative.

•    Gear Icon This is an Output Settings shortcut. Click to open the Output Settings window. (Same as selecting Output
> Output Settings).

•    Frames per Second Displays the broadcast frame rate (fps).

•    Bitrate  Displays the broadcast bitrate (kilobits per second).

•    CPU usage (percentage) This displays the current load on your CPU when streaming or recording in percent of
usage. The encoder affects the CPU usage more than any other parameter in Wirecast. If this value is high, you
should use a different encoder, or modify your encoder settings. If the CPU usage is near 95%, use a lower quality
video output to lower the bandwidth.

Note:   To avoid decrease in video quality, Wirecast should not be used at CPU usage above 80%. See the Telesteam
Website for suggested configurations.

•    Connection This displays the current connection quality. The bars indicate the amount of buffer memory used. High
bar count reflects low buffer use (good connection). Low bar count reflects high buffer use (poor connection and in
danger of broadcast errors). When one orange bar is displayed, the buffer is full.

Preview/Live Broadcast Area

   

When you open a new document, if you are not licensed for Studio or Pro, only the Live area displays. The Live area
shows what is broadcast to your viewers before the encoding or compression. If you are licensed for Studio or Pro, the
Preview window is displayed by default.

When AutoLive is off, you can make several changes without your viewers seeing the change. This is most useful when
you are using an engineer to run your broadcast. When you are making changes to your broadcast, you may want to see
those changes before broadcasting them. Preview allows you to do this.

To see the preview, select Preview from the Layout menu. This sets up the Main Window with the Preview Area on the
left and the Live Broadcast Area on the right. Clicking the Go button makes the preview shot become Live.
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Countdown Clock Display
The Main window displays a countdown clock whenever a video shot is playing. If you have multiple video shots
playing, click the gear menu icon to select which shot will be associated with the countdown clock.

 

Transition Controls
The transition area is in the middle of the Main Window:

   

There are two Transition buttons, but each can be configured to present one of many possible transition types. In the
image above, the two configured transitions are: Cut and Smooth. Since Smooth is selected (button darkened), any
transition executed by clicking Go is a smooth transition.

Changing Transitions
If you click the Cut button, it becomes selected and making it the current transition type:

 

You always have two different transition types available. You can also select one of the two buttons by pressing
Command+1 or 2 keys for the two transition types displayed.

If you click the down-arrow on the right side of either transition button, you can select a new transition to assign to that
button.
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Transition Speed
The transition speed is set by selecting Switch > Transition Speed. There are five settings: Slowest, Slow, Normal, Faster,
and Fastest.

 

Go Button
The Go Button (or Command+G) enables you to make a transition occur at any time.

    

 

Clicking the Go button does nothing when Wirecast is in AutoLive mode, except to update a live shot if you have made
changes to it using the Shot Editor.

Transition Editing
Some transitions have parameters that can be changed. To edit these parameters, select Edit Transitions from any of the
three transition button drop-down menus (Cut, Smooth, etc.). Select the transition you wish to edit from the drop-down
menu. Modify the displayed parameters as required. Each transition type has its own set parameters. Click OK when
finished.

 

Shot Tool Menu
The Shot Tool Menu provides a way to open lives sources, file sources, the Desktop Presenter program, shot graphics,
shot audio, and shot templates. The Shot Tool Menu is the circle to the right of the shot icons.

    

 

When you hover over the Shot Tool Menu it displays four menu items. Hover over and click a menu item to open it.

    

There are four menu items:
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Live Sources  Click the Live Sources button to display a list of live sources under the categories: System Device, Web
streams, and Scoreboard. When a live source is selected, it is added to the Shot Selection area as a new shot.

Shot Audio  Click the Shot Audio button to add an audio file shot. When selected a dialog window displays enabling
you to navigate to and select a file.

Desktop Presenter   To start Desktop Presenter, under the Sources menu select either New Remote Desktop Presenter
New Local Desktop Presenter. Remote Desktop Presenter presents a desktop from another computer in Wirecast. Local
Desktop Presenter allows you to present a portion or all of the desktop of the computer where Wirecast  is running.

You can also start DTP (local or remote) from the Shot Tool Menu.

 

File Sources   Click the File Sources button to display a list of file-based source categories: Video Shots, Picture Shots,
Music (audio) Shots, or a New (empty) Shot. When selected a file selection dialog window displays enabling you to
navigate to and select a file to become a shot. Select Add New Shot to add a new, untitled, generic shot without any
file-based resources attached.

Shot Selection Area
The bottom part of the Main Window contains the Shot Selection Area, also called the Shot List.

    

The shot icons can be made to display any live activity in the source it represents (cameras, streaming, etc.). See
Performance in the Preferences section for turning on Live Icons.

Changing Shots
Right-click on any shot to display the shot menu.

 

Change Source Select Change Source to change the source of your shot. Upon selection, a menu of sources will display
enabling you to make a selection.
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Change Audio Select Change Audio to change the audio of your shot. Upon selection, a menu of audio sources will
display enabling you to make a selection.

 

Change Template Select Change Template to change the template of your shot. Upon selection, a menu of templates will
display enabling you to make a selection.

 

Keyboard Shortcut You can create a keyboard shortcut to any shot. To do this, select Keyboard Shortcut, then select a
menu number to associate with that shot. After you have selected a menu number, that menu item is checked and the
number is displayed in the shot icon.

 

To take a shot using the assigned hotkey, press the number key assigned to that shot.

You can assign multiple shots to the same menu number as long as they are on different layers. When you use the
assigned hotkey all the shots assigned to it will be taken. Selecting a checked menu item will uncheck it and unassign
the shot.

Select Unmap All Keys to remove all hotkey assignments.

Edit Shot You can edit a shot by sliding the double arrows (located on the left side of the Preview window) to the
right, revealing the shot editing panel. You can also edit a shot by double-clicking on it, by right-clicking it and selecting
Edit Shot, by selecting Edit Shot from the Edit menu, or by selecting it and pressing the Command+E keys.
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Edit Shot, by selecting Edit Shot from the Edit menu, or by selecting it and pressing the Command+E keys.

Rename Shot You can rename a shot by right-clicking it and selecting Rename Shot, or by selecting Rename Shot from
the Edit menu. You can also rename a shot by selecting it and pressing the Command+R keys.

Duplicate Shot You can duplicate a shot by right-clicking it and selecting Duplicate Shot, or by selecting Duplicate Shot
from the Edit menu. You can also duplicate a shot by selecting it and pressing the Command+D keys.

Delete Shot You can delete a shot by right-clicking it and selecting Delete Shot, or by selecting Delete Shot from the
Edit menu. You can also delete a shot by selecting it and pressing the Command+Backspace keys.

Moving a Shot to Another Layer
You can move a shot to another layer by selecting Move to Layer from the Edit menu, then selecting the target layer
from the drop-down menu. Or, you can right-click the Shot and select Move to Layer. You can also click the title bar on
a shot, and drag the shot to a different layer.

When shots are created, they are assigned to a specific layer. They exist on that layer until they are moved or deleted.
(See Layers.)

Resizing the Shot Icons
You can resize the shot icons on any layer by clicking the up or down arrow on the left side of the layer window. Click
the up arrow to make all the icons larger; click the down arrow to make them smaller. Clicking the down arrow when
the shot icons are in their smallest state causes the layer window to become hidden.

     

To show or hide a layer window, click the side arrow that is displayed.

 

Layers

       

Wirecast allows you to put shots on any of five different layers. Layering shots enables Wirecast to merge them together,
from back (lowest layer) to front, to form a single visual image during broadcast.

When Wirecast first opens, two of the five layers of shots are displayed. You must scroll down (or expand the window)
to see the other three layers.

    

What is a Layer?
Layers are, by default, named 1 through 5. Layers determine the order when presenting images in the Live Broadcast
Area. The Bottom layer (5) is drawn first, then the other layers are added, in order, up to Layer 1. Using multiple layers
is a powerful way to show a company logo, a background, or a title, independent from each other.
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Changing Layers
To select a layer, click its LED to turn it on (click it again to turn if off). When a layer is selected, the selected shot in
that layer is displayed in the Preview/Live Broadcast area. If multiple layers are selected all selected shots are displayed.

       

 

Moving a Shot to Another Layer
A shot can be moved to another layer by clicking and dragging the shot from one layer to another within the Main Shot
window. When shots are created, they are assigned to a specific layer. They exist on that layer until you move them or
delete them.

AutoLive
AutoLive is turned on and off by selecting Switch > AutoLive (or by pressing the Command+L keys). When AutoLive is
on, changes made in the Shot List are automatically taken Live in the broadcast (using the current transition and
duration). If you click a shot when AutoLive is off, the shot is not sent to live broadcast. In this mode you take the shot
live manually, by clicking the Go button, or by pressing the Command+G keys.

Live Icons
You can, optionally, make your live source icon display its source (camera, Web stream, etc.) in real time. This means
that inside the icon, you will see what the live source sees.

       

To turn on the Live Icon option (default is off), select the Performance tab in Preferences, then check the Live Icons
checkbox. You can also adjust the frames per second rate of the display using the slider. Lower fps (frames per second)
rates reduce the time taken to adjust the live icon display. Higher fps rates provides a smoother display of the live icon
source.
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Note:   There tends to be a degrading quality when an icon is live. So, if the CPU is reaching its maximum, turn off
Live Icons to reduce CPU usage.
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